PROBLEM

Fonts in the ArcGIS Business Analyst infographic template display incorrectly after exporting to PDF

Last Published: July 25, 2024

Description

When creating an infographic and changing the font type within the template, the exported PDF does not display some fonts as expected. Although the font is rendered as expected when viewing the infographic in an app, the same font does not maintain its format in the exported PDF.

Cause

The server used to create the exported PDF does not support all fonts that are available within a local browser. Although a variety of fonts are available when creating and customizing an infographic template in the ArcGIS Business Analyst app, some of these options are not available on the server that generates the PDF export.

Additionally, some fonts used in creating the infographic template are not supported across all platforms. For example, the fonts Calibri, Candara, Consolas, Constantia, Corbel, and Segoe Script are not supported on Mac OS.

To circumvent these issues, it is recommended to use a font that is fully supported on the server side as well as across platforms when creating the infographic template. Any unavailable fonts are replaced when displayed or exported.

Solution or Workaround

  1. Navigate to ArcGIS Business Analyst Web App or ArcGIS Business Analyst Pro and open the infographic in the builder or editor.
  2. Update the font in the template to use one of the following:
    • Avenir Next
    • Arial
    • Georgia
    • Palatino
    • Times New Roman
    • Verdana
  3. Save the changes to the template.
  4. Export the PDF.

Article ID: 000033089

Software:
  • ArcGIS Business Analyst Pro
  • ArcGIS Business Analyst Web App

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