PROBLEM

Failed to sync and 'No permission to sync replica: <id>' error returned in ArcGIS Field Maps

Last Published: March 3, 2025

Description

In ArcGIS Field Maps, attempts to sync a layer from an offline map fail when the layer is added via URL from a stand-alone ArcGIS Server with embedded credentials to ArcGIS Online or Portal for ArcGIS. The following error message is returned:

Error:   
Sync Failed

In addition, the ArcGIS Field Maps logs further indicate the following error:

Error: 
Unable to complete operation.

No permission to sync replica: <id>

Cause

This is expected behavior. In ArcGIS Field Maps, a replica is created, and the owner is assigned in ArcGIS Server when the web map is first taken offline. In this instance, the owner's username is set based on the stored credentials in ArcGIS Server at the time the web map is taken offline. If the stored credentials are later updated, a mismatch occurs between the original owner and the user attempting to sync. The sync fails if the new username is not the original replica owner or an admin user with sufficient privileges. Refer to ArcGIS REST APIs: Sync permissions for more information.

Solution or Workaround

Note:
Only an organization's default administrator or a member with administrative privileges can perform the following workflows.

Update the stored credentials

Update the stored credentials for the ArcGIS Online or ArcGIS Enterprise item to revert to the original user.

Temporarily assign administrative privileges

Assign temporary administrative privileges to the member to allow the required layer to sync. Refer to ArcGIS Server: Modify a user or ArcGIS Server: Modify a role for more information.

Note:
As best practice, sync and delete existing maps in ArcGIS Field Maps before updating the username. Then, download a new offline area to create a new replica using the new username.

Article ID: 000034150

Software:
  • ArcGIS Online
  • Portal for ArcGIS
  • ArcGIS Enterprise 11 3
  • ArcGIS Field Maps Android
  • ArcGIS Field Maps iOS
  • ArcGIS Enterprise 11 2
  • ArcGIS Enterprise 11 4

Receive notifications and find solutions for new or common issues

Get summarized answers and video solutions from our new AI chatbot.

Download the Esri Support App

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options