PROBLEM

Failed to run service backup and service export in ArcGIS Server

Last Published: July 28, 2021

Description

When running a webgisdr backup utility, an ArcGIS Server backup, or running the servicesExport function, the action may fail. Occasionally, the following error message is returned:

Error:   
Unsupported Image Type

Cause

This error is tied to a service metadata file, and the thumbnail's base64 encoding within the metadata file. Republishing the service fixes the issue. Identifying the corrupted service is important as errors are not displayed in the log pointing to the corrupted services.

Solution or Workaround

The steps below describe how to identify corrupted services in ArcGIS Server using Process Monitor (Procmon).

  1. Download Process Monitor from the Microsoft Sysinternals website, Process Monitor for Windows.
  2. Extract the zip file contents to a preferred folder, and run the .exe file according to the system requirements (32-bit or 64-bit).
  3. In the Process Monitor-Sysinternals window, click the Filter tab, and click Filter.
  4. In the Process Monitor Filter window, include the processes to track the activity. From the drop-down menu:
    1. Change Architecture to Detail
    2. Change is to contains
    3. In the empty field type iteminfo.json
    4. Ensure the drop-down on the right is set to Include
    5. Click Add, and click OK to close the window.
procmon-filter.png
  1. Log in to ArcGIS Server admin endpoint. Click services > exportServices.
  2. In the Export Services page, click Export to run the export process.
Note:
It is not necessary to define the parameters for the export process to run successfully.
  1. Process Monitor shows a number of lines representing the 'esriinfo' folder structure of the backed up services.

The image below displays a corrupted service, highlighted in Process Monitor. The corrupted service is identified by the number of displayed items, and the highlighted service indicates only three items are displayed. This is the service to republish.

Image of the corrupted service highlighted in the Process Monitor window

A successfully backed up service must display seven items, and the proper details listed as follows:

0: ..
1: .JPEG
2: iteminfo.json
3: iteminfouploadslist.dat
4: lifecycleinfos.json
5: manifest
6: metadata
7: thumbnail
Note:
System/Utility services display only three items. This is by default, and does not indicate the service is corrupted or in a bad state.

Article ID: 000022507

Software:
  • Portal for ArcGIS
  • ArcGIS Server

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