PROBLEM

Failed to deploy error returned when deploying solutions in the ArcGIS Enterprise portal

Last Published: October 9, 2025

Description

When deploying a solution in the ArcGIS Enterprise portal, the following error message is returned:

Error:
<Solution> failed to deploy
The error message displayed when deploying ArcGIS Solutions

This error prevents the successful deployment of the selected solution and its associated content.

Cause

This issue occurs when HTTPS is not enabled for the portal. HTTPS is required for secure communication during solution deployment.

Solution or Workaround

Enable HTTPS-only communication in the ArcGIS Enterprise portal. Refer to Portal for ArcGIS: Configure HTTPS for instructions. In Step 3, toggle on the Allow access to the portal through HTTPS only toggle button.

The enabled Allow access to the portal through HTTPS only setting

Article ID: 000038225

Software:
  • ArcGIS Solutions
  • Portal for ArcGIS
  • ArcGIS Enterprise

Receive notifications and find solutions for new or common issues

Get summarized answers and video solutions from our new AI chatbot.

Download the Esri Support App

Related Information

Discover more on this topic

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options