PROBLEM

Error 404 is returned when launching ArcGIS Insights via Portal for ArcGIS

Last Published: July 21, 2020

Description

In ArcGIS Enterprise, users are licensed to use ArcGIS Insights, and the ArcGIS Insights app icon is present in the Portal for ArcGIS app launcher. Attempts to click the ArcGIS Insights app icon in the app launcher return the following error message:

Error:   
404 Page not found.
Image of the error message

Cause

This error occurs due to the following causes:

  • There is a missing or corrupted installation of ArcGIS Insights.
  • Portal for ArcGIS service account cannot access the ArcGIS Insights file directory.
  • Portal for ArcGIS and ArcGIS Server run on different machines in a distributed environment, and ArcGIS Insights is not installed on either machine.
  • The ArcGIS Insights version is not compatible with the Portal for ArcGIS upgrade version.

Solution or Workaround

Use the workaround below to resolve.

  1. Ensure ArcGIS Insights is installed on all machines in the deployment of Portal for ArcGIS, and on all server machines for ArcGIS for Servers in the hosting server sites.
  2. Ensure the insights folder is present. The default installation directories are as follows:
C:\Program Files\ArcGIS\Portal\apps for the portal client application.

C:\Program Files\ArcGIS\Server for the server component
Note:
If there is no insights folder in the default installation directory, ArcGIS Insights is not installed on the Portal for ArcGIS machine. Reinstall a compatible version of ArcGIS Insights. Refer to ArcGIS Insights: Install ArcGIS Insights in ArcGIS Enterprise for more information.

If the insights folder exists in the default installation directory, check the version of ArcGIS Insights and confirm the compatibility with the current Portal for ArcGIS version.
  1. Check if Portal for ArcGIS is recently upgraded. Upgrading Portal for ArcGIS does not upgrade ArcGIS Insights simultaneously. Refer to ArcGIS Insights: Compatibility With ArcGIS Enterprise for more details.
Note:
If the versions of Portal for ArcGIS and ArcGIS Insights are not compatible, upgrade ArcGIS Insights to a compatible version. Refer to ArcGIS Insights: Upgrade Insights in ArcGIS Enterprise for more information.
  1. Ensure the Portal for ArcGIS service account is connected to the default file path. Follow the workaround provided in Error: The ArcGIS Server is not able to connect to the specified directory.

Article ID: 000023124

Software:
  • Portal for ArcGIS
  • ArcGIS Server
  • ArcGIS Insights

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