PROBLEM

Enterprise geodatabase contents not displayed in ArcGIS Pro

Last Published: May 20, 2025

Description

After upgrading ArcGIS Pro to version 3.2 or subsequent versions, the contents of the enterprise geodatabase connected to SQL Server or Oracle Server are not shown in ArcGIS Pro. Attempts to create a new feature class within the enterprise geodatabase are successful, but the created feature class does not appear in the geodatabase contents within ArcGIS Pro. Additionally, creating a new enterprise geodatabase connection is successful, but the contents of the newly created enterprise geodatabase are not displayed in ArcGIS Pro.

Cause

The contents within the Index folder are corrupted. This may be caused by software updates, improper shutdowns, or other system-related issues.

Solution or Workaround

Note:
The AppData folder is hidden by default. Refer to the Show hidden files drop-down in Microsoft Support: Common File Explorer options for instructions to display hidden folders.
  1. In File Explorer, navigate to the Index folder, which is located by default at:
C:\Users\<username>\AppData\Local\ESRI\Index
  1. Delete all the content within the Index folder.
  2. Restart ArcGIS Pro and create a new enterprise geodatabase connection. Refer to ArcGIS Pro: Connect to the database for instructions.
Note:
Restarting ArcGIS Pro after deleting the contents of the Index folder recreates the contents of the folder, ensuring the contents are up-to-date and correctly configured.

Article ID: 000034285

Software:
  • ArcGIS Pro

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