PROBLEM

Defining an area using the Draw Polygon option in ArcGIS Business Analyst Web App returns a prompt to change the country/area selection

Last Published: April 25, 2020

Description

In some instances, defining an area using the Draw Polygon option in ArcGIS Business Analyst Web App returns a prompt that reads, 'This area is not in the country or area you selected and can't be used for analysis and reports. Change your country/area selection above and try again.'

The error message

Cause

This issue occurs when the polygon is drawn on the map of a country other than the ones specified under Preferences.

Solution or Workaround

In ArcGIS Business Analyst Web App, change the default country preference to the desired country, that is, where the features are created and analyses performed.

Note: 
For more information on setting the preference, refer to ArcGIS Business Analyst: Set Preference - Change the country or area.

Specify the preference using one of the methods below:

  • Select the preference from the country names drop-down list located at the top-right corner.
  • Click Preferences The Preferences icon. > General > Settings. Under Options, specify the preferred country in the Select field. Click Save and Close.

The example below shows how changing the default preference from USA to Canada allows the user to create a polygon to define an area in Canada.

Change the country preference.
Note:
Creating a polygon that spans across two countries does not return the prompt, but running a report on the polygon only returns the result for the preferred country. For example, a polygon covering parts of USA and Canada only returns data for USA if the preferred country is USA.

This is the polygon drawn at the boundary.

Article ID: 000022745

Software:
  • ArcGIS Business Analyst Web App

Receive notifications and find solutions for new or common issues

Get summarized answers and video solutions from our new AI chatbot.

Download the Esri Support App

Related Information

Discover more on this topic

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options