PROBLEM

Creating a new survey causes ArcGIS Survey123 Connect to stop responding

Last Published: April 27, 2022

Description

When creating a new survey in ArcGIS Survey123 Connect, the application stops responding when converting the XLSForm, as seen below.

Screenshot of Survey123 Connect for ArcGIS in an indefinite loop when converting XLSForm

If Survey123 Connect is closed and reopened, and the survey is refreshed, the following error is displayed:

Error:   
Error: 201 Error transferring https://<SomeURL>/slx2xform - server replied: Forbidden

Cause

This issue occurs because the Survey123 REST API URL in Survey123 Connect Settings is modified, and is not the default web address that connects to the ArcGIS conversion service. The conversion service converts XLSForm files to the xForm format that can be displayed in Survey123 Connect and the field app. When Survey123 Connect is unable to connect to the conversion service, the conversion fails.

Solution or Workaround

To reset the Survey123 REST API URL to the default web address of the conversion service, follow the steps below.

  1. In Survey123 Connect, click the menu icon on the top-right of the screen.
  2. Click Settings Settings icon..
  3. Click the Portal tab. Select ArcGIS Online as the active ArcGIS Portal.
Screenshot of active ArcGIS Portals with ArcGIS Online highlighted
  1. Click the Services tab.
  2. Type https://survey123.arcgis.com/api in the Survey123 REST API Url field. Click OK.
Screenshot of the default URL in the Survey123 REST API Url.
  1. Click New Survey to create the survey.

Article ID: 000016912

Software:
  • ArcGIS Survey123 Connect

Receive notifications and find solutions for new or common issues

Get summarized answers and video solutions from our new AI chatbot.

Download the Esri Support App

Related Information

Discover more on this topic

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options