PROBLEM

Citrix Troubleshooting

Last Published: April 25, 2020

Description

This article contains information on what Citrix is, provides questions to help troubleshoot ESRI application troubleshooting on Citrix and provides links to documents with further Citrix information and troubleshooting.

Cause

ArcGIS 8.x, ArcInfo Workstation (8.x and 7.x), and ArcView 3.x are supported in the Citrix environment but there are some limitations that need to be considered.

Citrix implementation involves both a Citrix server and a Citrix client. The Citrix Metaframe program is installed on the server while a free Citrix client is installed on each client machine. Citrix Metaframe is installed on top of Windows Terminal Services (WTS) and extends the functionality of WTS. The Citrix server can allow clients to access either the entire server desktop or a published application. Published applications are the most common industry use.

Applications are installed on the Citrix server and published for use by a Citrix client. Citrix technology allows non-Windows clients to access the terminal server making good use of a company’s existing hardware. Once a client is configured to run a published application, a shortcut to the application will exist on the client machine.

When the application is started it appears to run on the client when it is actually running on the Citrix server. This allows application management from a central location where upgrades and installations are quick and only have to be performed on the Citrix server. This also allows for purchasing 1 powerful server and many less powerful clients since all processing and application run time is at the server’s expense. One application installed on a Citrix server can be accessed by many Citrix clients.

Solution or Workaround

The following are questions, experiences and suggestions to aid in troubleshooting:

Note:
Several links for support and general information on using ESRI products in a Citrix environment are listed in the Related Information section below.

· Does the same problem occur when running the application while sitting at, logged directly into the server?

· Are there any other management framework tools installed on the Citrix server (PowerFuse is an example)?

· Is it possible to take the management framework application out of the equation?

· Does the same problem occur when the management framework application is uninstalled?

· Check the application and system event viewer on the Citrix server to see if there is any information to narrow down the problem.

· Filemon is a tool that allows you track a specific .exe and see all of the files and folders that the executable accesses. Download filemon from www.sysinternals.com and trace the executable in question. Since security is a big issue for Citrix implementations and is handled primarily through Windows, watch for files or folders that cannot be accessed.

· We have also observed Citrix login timing issues involving both mandatory profile management and printer defaults. Citrix login process often include the launching of ArcMap. In these cases registry keys and system setup processes were not completed before ArcMap was launched. This resulted in missing functionality and unmapped printers. The solution involved a user written VB application that slowed/controlled the timing of the ArcMap launch.

Article ID:000007090

Software:
  • Legacy Products
  • ArcMap 9 x
  • ArcMap 8 x

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