Description
When a member leaves the organization, the administrator needs to transfer the content before the account of the member is deleted. However, at times, the Change Owner option is not displayed when the ownership of the web map is changed, as shown in the image below.
Cause
- The web map contains or contained offline map areas at one point. At times, even after identifying the web map and removing the offline areas from the web map, the Change Owner option is still not displayed. This may be due to a sudden connection cut when removing the offline areas, causing 'Offline Map Areas' to still be listed in the JSON script of the web map.
- The web map may be corrupted.
Solution or Workaround
Delete the offline areas from the web map
- Log in to ArcGIS Online and click Content > My Content.
- Search for and click the web map.
- On the item details page, click Settings.
- At the top of the page, click the Offline tab.
- In the Offline Map Areas section, click Manage Offline Areas.
- In the Offline map areas pane, check the offline areas check box and select Delete from the drop-down menu.
- At the top-right corner of the page, click Close to return to the Settings page.
- In the Offline section, disable the Enable offline mode toggle.
- Click Save.
Note:
If the issue persists, contact Esri Support Services.
Save a copy of the web map in ArcGIS Online
In ArcGIS Online, make a copy and save the map as a new web map using the 'Save as' option. Refer to ArcGIS Online: Save maps (Map Viewer) for further instructions.
The image below shows the Change Owner option displayed in ArcGIS Online.