PROBLEM

ArcMap Services cannot be viewed

Description

When a client requests an image from an ArcMap Service no image is returned.

Cause

There may be a number of reasons for this including:

1. The ArcIMS site output directory path does not match the virtual directory path setting in the web server.

2. The ArcMap document that you are serving contains an empty layer, that is a layer without any features, or an empty group layer.

3. The map you are serving contains layers referencing ArcSDE data or layers referencing database data using direct connect. If the connection to the ArcSDE server or to the database is broken no features will be returned and the map image will be blank.

4. The link between a layer in the map and the data source the layer is referencing has been broken.

5. One of the data frame names of the ArcMap document being served contains a slash (\ or /).

Solution or Workaround



  1. Check to make sure the path of the site output directory, set in ArcIMS site properties, matches the path set for the virtual output directory or output URL (web server).
  2. Check to see if the ArcMap document you are serving contains empty layers or group layers. If so:
    1. Delete the empty layers or empty group layers from the map.
    2. Save the map.
    3. Refresh the ArcMap Service.
  3. If the ArcMap document contains ArcSDE layers, do all the following:
    1. Remove all ArcMap Services using data originating from the ArcSDE server that is down.
    2. Wait for the ArcSDE server to go back on line.
    3. Re-add the ArcMap Services.

    Note:
    For ArcIMS versions 4.0 and 4.0.1 there is no automatic recovery for ArcMap Services when the connection to an ArcSDE server is reestablished. The service needs to be recreated manually or through recycling. Until this is done the features will not draw.

  4. Open the ArcMap document being served and check for broken data links. A red exclamation mark next to the layer name in the TOC signifies a broken data link. If the map contains layers with broken links, do all the following:
    1. Repair the link. Refer to the Help topic "Repairing broken data links" for more information.
    2. Save the map.
    3. Refresh the ArcMap service.
  5. Check the ArcMap document to see if there are slashes in data frame names. If so:
    1. Remove all slashes from data frame names.
    2. Save the map.
    3. Refresh the ArcMap service.

Article ID:000005122

Software:
  • Legacy Products

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Related Information

Discover more on this topic