PROBLEM

ArcMap freezes when converting CAD files into GDB (DumpFile generated without crashing)

Last Published: May 3, 2024

Description

When attempting to run the CAD to Geodatabase tool and importing CAD files into ArcGIS Desktop 10.8.2, geoprocessing fails and the software sends a message informing of a fatal failure.

Cause

When this occurs, a dump file is generated with information similar to that shown in the images below. The dump file was analyzed using WinDbg Preview. The cause of the error is the Module CadFDB.dll that can be found in the the following path:

C:\Program Files (x86)\ArcGIS\Desktop10.8.2\bin\CadFDB.dll

image.png

image.png

Solution or Workaround

Because the module CadFDB.dll belongs to an ArcGIS path, the solution is to repair the software and then repeat the process of importing CAD files into the geodatabase.

If the error persists, perform a clean uninstall of the software and the repeat the process.

Article ID: 000028281

Software:
  • ArcMap 10 8

Receive notifications and find solutions for new or common issues

Get summarized answers and video solutions from our new AI chatbot.

Download the Esri Support App

Related Information

Discover more on this topic

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options