Description
** Internal Publish Only! This article may contain information that is not intended for external circulation. **
No available Spatial Servers are listed in ArcIMS Administrator. MapServices cannot be added because no Virtual Servers are available.
Cause
There are many causes for this problem, among which are a port conflict, DNS resolution problem, and misconfiguration.
Solution or Workaround
- Verify that all the ArcIMS services are running, especially Monitor.
- Open the Monitor.properties file in a text editor and verify that the "registryHost" variable is set to the name of the machine where the ArcIMS Application Server is running. This file can be found in the "Monitor" directory(Windows: "C:\Program Files\ArcGIS\ArcIMS\Server\Monitor" and Solaris: "$AIMSHOME/Monitor). For example:
Code:
### The name of the computer on which the ArcIMS Application Server is running.
registryHost=<Application_Server_Machine_name>
- Verify that the registry port (set during ArcIMS install, default 5353) is not in use by another application.
Use the 'netstat' command to see if a port is in use.
Make sure the monitor service is stopped. Open a command prompt and type: Netstat
In the list, look for "machinename:5353" and connection "ESTABLISHED"
If port 5353 shows up in the list, it is being used by another application. Change "RegPort" in Appserver.properties and "RegistryPort" in monitor.properties to something else. - Ping the Web Server from the Spatial Server machine.
Open a command prompt and type:
Code:
ping machinename
Write down the IP address. What is the IP address that is returned? Open your Hosts file (c:\WinNT\system32\drivers\etc\). If the IP address is different then what appears in the Hosts file, then add the IP address and Spatial Server machine name that you have written
down. For example:
Code:
127.0.0.1 localhost
46.1.30.44 Spatial_Server_Machinename
Save the Hosts file. Also try the same test on the Web Server, and make the IP modifications to the Hosts file if necessary.
Make sure that the web server has a static IP (i.e. doesn't get its IP
from a DHCP server.
- Firewall Conflict
There are two issues to consider in order to make client requests and
server responses go through a firewall:
The port on which the Application Server is running (connector port,
default 5300), needs to be open through the firewall to the web server.
The connector port is set during the ArcIMS installation, and
firewall software can be used to open up the connection to that port.
Note: The registry port (set during ArcIMS install, default 5353) allows
communication between the Spatial Server, Virtual Servers, and
Application Server and should not be an issue since they are on the same
side of the firewall.
- Examine the log files.
For the Application Server, open the appserver.properties file and set the following values
Code:
debug=True
logToFile=True
For the Monitor, open the monitor.properties file and set the following values
Code:
debug=True
logToFile=True
Restart the services, and log files will be created in separate log directories under appserver and monitor.
Check the log files for errors, and port conflicts.