PROBLEM

ArcGIS Pro is unable to verify licensing through the licensing portal

Last Published: April 25, 2020

Description

Attempts to log in to Portal for ArcGIS using ArcGIS Pro fails with the repeated prompting of the licensing portal login dialog window.

Cause

This issue is caused by an inaccurately defined portal configuration file (.json). This makes Portal for ArcGIS unable to identify the License Manager over the network despite using a valid URL to login.

In some environments, if the hostname in the portal configuration file (created in Step 19 of ArcGIS Help: Configure ArcGIS Pro licenses for your organization) is not defined in a fully qualified domain name (FQDN) recognizable by the license server, Portal for ArcGIS is unable to connect to the license manager to verify licensing.

Solution or Workaround

  • Update the portal configuration file

    This workaround can only be applied after successfully configuring the licenses for ArcGIS Pro. For steps on how to configure licensing for ArcGIS Pro, refer to ArcGIS Help: Configure ArcGIS Pro licenses for your organization.
    1. Browse and open the portal configuration .json file (generated from Step 19 in the link provided above) with a text editing software program such as Notepad++. 
    2. Search for the value Hostname and ensure the values are defined as the machine's FQDN. For more information on fully qualified domain names, refer to ArcGIS Help: Domain name service (DNS) and fully qualified domain name (FDQN) requirements.
      Note:
      The value Hostname is typically found twice in the portal configuration .json file: once in the middle, and once at the end.
      
    3. Save the .json file. 
    4. Access the Portal Admin API via https://portal.<domain>.com/webadaptor/portaladmin.
    5. Navigate to Home > System > Licenses.
    6. If there are already licenses imported into the Portal site, remove these entitlements by clicking Remove Entitlements.
    7. Click Import Entitlements > Choose File, and select the updated .json file with the FQDN of the licensing server. Click Import.
    8. Verify the entitlements applied by clicking Get Entitlements.
    9. Attempt to open ArcGIS Pro. 
  • Remove old registry entries of ArcGIS Pro
    In some instances, the system registry contains information of older versions of ArcGIS Pro. Removing the registry entries allows the system to recognize the license changes made to ArcGIS Pro.
    Warning:   
    The instructions below include making changes to essential parts of your operating system. It is recommended that you backup your operating system and files, including the registry, before proceeding. Consult with a qualified computer systems professional, if necessary.
    
    Esri cannot guarantee results from incorrect modifications while following these instructions; therefore, use caution and proceed at your own risk.
    1. Click the Windows Start button > type regedit in the Windows search bar (open the Registry Editor).
    2. Search for the following registry entries, and remove or rename them:
      HKEY_CURRENT_USER\Software\ESRI\ArcGIS Online For Pro
      HKEY_CURRENT_USER\Software\ESRI\ArcGISPro
      HKEY_CURRENT_USER\Software\ESRI\ArcGISPro1.0
      HKEY_LOCAL_MACHINE\SOFTWARE\ESRI\ArcGISPro
      
    3. Reboot the machine.

Article ID: 000013083

Software:
  • ArcGIS Pro
  • Portal for ArcGIS

Receive notifications and find solutions for new or common issues

Get summarized answers and video solutions from our new AI chatbot.

Download the Esri Support App

Related Information

Discover more on this topic

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options