PROBLEM

ArcGIS Pro fails to start with a serious application error

Last Published: August 2, 2024

Description

When starting ArcGIS Pro, the application fails and returns the following error:

Error:
ArcGIS Pro has encountered a serious application error and is unable to continue.

User-added image

Cause

This is a generic error message that can be returned due to various causes, however when starting ArcGIS Pro, this error often occurs because the user.config file is corrupted.

Solution or Workaround

Create a new .config file
To locate and delete the corrupted user.config file by following the steps below:

Note:
It may be necessary to enable viewing of hidden folders to view the AppData folder in Windows. For more information, refer to Microsoft: Show hidden files.
  1. Navigate to the following folder path:

For Versions of ArcGIS Pro before 2.5:

C:\Users\<USERNAME>\AppData\Local\ESRI\ArcGISPro.exe_StrongName_<STRONGNAME>\<VERSIONNUMBER>

For Versions of ArcGIS Pro after 2.5:

C:\Users\<USERNAME>\AppData\Roaming\ESRI\ArcGISPro.exe__StrongName_<STRONGNAME>\<VERSIONNUMBER>
  1. Delete the user.config file.
  2. Start ArcGIS Pro.

Rename the ESRI folder
By renaming the ESRI folder to a name other than ESRI, a new ESRI folder is created with a new .config file when starting ArcGIS Pro.

  1. Navigate to the following path:

For Versions of ArcGIS Pro before 2.5:

C:\Users\<USERNAME>\AppData\Local

For Versions of ArcGIS Pro after 2.5:

C:\Users\<USERNAME>\AppData\Roaming
  1. Rename the ESRI folder (for example, to 'ESRI-old'.)
  2. Start ArcGIS Pro.

Article ID: 000015754

Software:
  • ArcGIS Pro

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