PROBLEM

ArcGIS Monitor is unable to receive metrics from ArcGIS Server despite successful registration

Last Published: August 12, 2025

Description

In some instances, after successfully registering ArcGIS Server as a component in ArcGIS Monitor, no metric data displays for the associated component in ArcGIS Monitor. The ArcGIS Server component appears correctly in the ArcGIS Monitor interface, services are listed, and the observer status is nominal. However, the elements show a "No data available" message, indicating that metric collection is not functioning as expected.

Additionally, when running the ArcGIS Server metric observer in ArcGIS Monitor, the process fails and returns the following error message:

Error:
Failed to read ArcGIS Server usage report

Cause

The ArcGIS Server usage report takes longer than the default request timeout of 30 seconds to generate, causing the metrics observer to fail.

Solution or Workaround

  1. Stop the ArcGIS Monitor Server service.
    1. In the Windows search bar, type services and click the Services icon.
    2. In the Services window, navigate to the ArcGIS Monitor Server service and click Stop.
  2. In File Explorer, navigate to the .env file, which by default, is located in:
C:\Users\<ArcGIS_Monitor_Service_Account>\AppData\Local\ESRI\ArcGISMonitor\config-store-server
  1. Right-click the .env file and open the file in a text editor, for example, Notepad.
  2. In the text editor, navigate to the HTTP_REQUEST_TIMEOUT variable and edit the value to 180.
  3. Save the .env file and close the text editor.
  4. Start the ArcGIS Monitor Server service.
    1. In the Windows search bar, type services and click the Services icon.
    2. In the Services window, navigate to the ArcGIS Monitor Server service and click Start.
Note:
The following steps only apply to ArcGIS Monitor version 2024.x and above. Do not proceed with these steps if using an earlier version.
  1. Stop the ArcGIS Monitor Agent service.
    1. In the Windows search bar, type services and click the Services icon.
    2. In the Services window, navigate to the ArcGIS Monitor Agent service and click Stop.
  2. In File Explorer, navigate to the .env file, which by default, is located in:
C:\Users\<ArcGIS_Monitor_Service_Account>\AppData\Local\ESRI\ArcGISMonitor\config-store-agent
  1. Right-click the .env file and open the file in a text editor, for example, Notepad.
  2. In the text editor, navigate to the HTTP_REQUEST_TIMEOUT variable and edit the value to 180.
  3. Save the .env file and close the text editor.
  4. Start the ArcGIS Monitor Agent service.
    1. In the Windows search bar, type services and click the Services icon.
    2. In the Services window, navigate to the ArcGIS Monitor Agent service and click Start.

Article ID: 000034407

Software:
  • ArcGIS Monitor Server
  • ArcGIS Server
  • ArcGIS Enterprise

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