Description
There are entries in the ArcGIS Server logs about Server extensions expiring, even after confirming that the ArcGIS Server license is valid.
Cause
There are still expired ArcGIS Server extension licenses located in the keycodes directories.
Solution or Workaround
- Open the ArcGIS Server keycode files in a text editor.
Note:
The following are locations for the keycode files:
- C:\Program Files (x86)\ESRI\License10.x\sysgen
- C:\Program Files\ESRI\License10.x\sysgen
- View the format and turn off word wrapping (In Notepad, Format > uncheck Word Wrap.)
- Check for any lines that have an expired date, and delete those lines from the file.

- Click File, and Save.
- Restart the ArcGIS Server Windows service. The first workaround step in the following Esri Support document describes how to restart the ArcGIS Server Windows service: Problem: Unable to start or stop services in ArcGIS for Server.
- Check the ArcGIS Server logs. The following ArcGIS Server document describes this in detail: Work with server logs.