PROBLEM

An HTTP line is larger than 4096 bytes in GeoEvent Server logs

Last Published: May 21, 2021

Description

When using a spatiotemporal big data store with ArcGIS GeoEvent Server, the ArcGIS GeoEvent Server machine may suffer from performance issues, displaying the following error message in the log files:

Error:   
Error: {"error":{"root_cause":[{"type":"too_long_frame_exception","reason":"An HTTP line is larger than 4096 bytes."}]

This error message may fill up the log files.

Cause

ArcGIS GeoEvent Server attempts to make a request of 4096 bytes or higher to the Elasticsearch associated with the spatiotemporal big data store. This is not allowed by Elasticsearch, preventing the request and returning the error message.

Solution or Workaround

Perform the workaround below to resolve the issue.

Note:
The following workaround must be performed on all spatiotemporal big data store machines deployed in the ArcGIS Enterprise environment.
  1. Log in to the spatiotemporal big data store machine, and stop the ArcGIS Data Store service.
  2. Navigate to the following directory:
C:\Program Files\ArcGIS\DataStore\framework\runtime\elasticsearch_<latest_version_number>\config\
  1. Open the elasticsearch.yml file with a text editor software.
  2. Search for the following line:
#http.port: 9220
  1. Add the following line below the line in Step 4, and save the .yml file:
#http.max_initial_line_length: 10kb
Note:
The value for '#http.max_initial_line_length' may need to be set to a higher value, depending on the size of the request made by ArcGIS GeoEvent Server.
  1. Restart the ArcGIS Data Store service.

Article ID: 000025323

Software:
  • ArcGIS Server

Get support with AI

Resolve your issue quickly with the Esri Support AI Chatbot.

Start chatting now

Related Information

Discover more on this topic

Get help from ArcGIS experts

Contact technical support

Start chatting now

Go to download options