PROBLEM

New Monitor Agents cannot be added after upgrading to ArcGIS Monitor 2023.3.1

Last Published: January 20, 2025

Description

After upgrading to ArcGIS Monitor 2023.3.1, new Agents are unable to be added with the following error:

"Failed to fetch".

image of error whe connecting to the Monitor server

Cause

 

When inspecting network traffic, a 'cross-origin request blocked' (CORS) error is returned, as shown in the next image:

image001.png

With the CORS error, we see the request from the Agent machine to the Server machine to get a token is blocked, and the registration fails due to a network error.

Solution or Workaround

Opening the Monitor Site Admin URL on the Agent machine and just signing in, allowed the new Agent to continue to register from within another browser tab.

  1. On the Agent machine, open a new tab from within the browser and navigate to the Monitor Server Site Admin page.
  2. Log-in to the Monitor Server site.
  3. Go back to the tab to register the Agent and click the Next button without the "Failed to fetch" error.

Article ID: 000032368

Software:
  • ArcGIS Monitor Server

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