Description
The Map tab in an ArcGIS Enterprise portal provides access to Map Viewer, which allows users to create, edit, and analyze maps. We can visualize spatial data layers, add our own data, configure symbology, and perform spatial analysis. It is a powerful tool for creating custom maps tailored to specific needs.
Cause
The absence of the Map tab in ArcGIS Enterprise portal could be due to several reasons. These are some common issues:
- Portal licensing
- Map service availability
- URL or permission related issues
- Portal configuration
- Browser compatibility
- Portal version compatibility
Solution or Workaround
If the Map tab is missing in your ArcGIS Enterprise portal, here are some steps you can take to troubleshoot and potentially resolve the issue:
- Restarting the ArcGIS Enterprise machine sometimes resolves the issue.
- Check the licensing options.
- Ensure that the users experiencing this issue have the appropriate licenses.
- Assign the Add-on license of Essential Apps or try changing the user type to something that includes the Essential Apps bundle.
Note:
It appears that users with an ‘Advanced’ license might not see the Map tab.
Verify URLs and ports
- Confirm that the portal URL is accessible.
- Ensure that all required ports are allowed through both the machine and network firewall.
- Perform re-indexing from Portal Admin, System> Indexer > Reindex > Full > Start.
- Stop the System services (Run > services.msc) for ArcGIS Data Store, ArcGIS Server and Portal for ArcGIS.
- Open Task Manager to confirm that the services have stopped completely.
- Start the services in the following order:
- Portal for ArcGIS
- Hosting federated ArcGIS Server
- ArcGIS Data Store
- Review the Basemap settings and verify that your Basemap gallery and default basemap settings are set to Default in My Organization > Edit Settings > Map.