PROBLEM

License Manager unable to read Options File

Last Published: May 4, 2021

Description

When using an options file with ArcGIS License Manager, the license manager does not recognise the options file, and returns the following error message in the debug log:

Error: "(ARCGIS) CANNOT OPEN options file "=""

Cause

The service.txt file is configured incorrectly, and includes spaces in the 'PORT=<port_number>' parameter. This prompts the license manager to connect through an invalid port, as the port is incorrectly specified in the services.txt file.
Below is an example of the incorrect 'PORT=<port_number>' parameter with additional spaces:

[CODE BLOCK]: PORT = <port_number>

Below is an example of the correct parameter (no spaces):

[CODE BLOCK]: PORT=<port_number>

Solution or Workaround

  1. Navigate to C:\Program Files (x86)\ArcGIS\LicenseManager\bin, and open the services.txt file.
  2. Remove the spaces in the 'PORT=<port_number>' parameter. Save the file.
  3. Launch License Server Administrator. Click Re-read Licenses > Apply > OK.

Article ID: 000025364

Receive notifications and find solutions for new or common issues

Get summarized answers and video solutions from our new AI chatbot.

Download the Esri Support App

Related Information

Discover more on this topic

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options