PROBLEM

Incompatibilities when using ArcGIS Pro with Visual Studio

Last Published: January 30, 2026

Description

In some scenarios where ArcGIS Pro is installed on the same machine with Microsoft Visual Studio, this may lead to issues opening new or existing ArcGIS Pro files. Moreover, with the retirement of ArcGIS Pro versions 3.1.x in April 2026, supported software environments have changed in subsequent releases.

Cause

By default, ArcGIS Pro has specific requirements that must be considered when working alongside other programs. This is because these programs might share certain features or drivers that can update automatically, potentially impacting the workflow in ArcGIS Pro. It is possible that if a different version of Visual Studio has been installed, ArcGIS Pro may crash or fail to open existing and new projects. The issue arises because each version of ArcGIS Pro corresponds to a specific .NET Framework version that it supports.

Normally, every program has its own system requirements. But in some scenarios, these requirements may conflict. In this scenario, the system requirements of Visual Studio and ArcGIS Pro (depending on the versions installed) may be incompatible, and specifically be caused by the .NET Framework.

To properly run ArcGIS Pro, there are certain system requirements that must be met. Simultaneously, Microsoft Visual Studio has a specific set of requirements that should also be met to ensure proper performance.

When both products are on the same machine, and depending on the versions used, consider whether their system requirements are compatible because this may lead to conflicts. More specifically, the .NET Framework version used might be incompatible with ArcGIS Pro.

Solution or Workaround

Ensure that the system requirements for both programs are compatible. For more information, you can refer to these resources:

In the case you have installed a mismatched version and encounter issues with ArcGIS such as being unable to open projects or Pro becoming unresponsive while launching, consider the following:

  • Based on your priorities, keep the program for use and ensure to uninstall the other program with its respective .NET Framework version.
  • Upgrade either the ArcGIS Pro version or Microsoft Visual Studio, so the newer system requirements match the .NET version between them.

With the rollout of later versions of ArcGIS Pro, remember to check which .NET Framework versions are supported for the release, as it could impact the seamless integration between both environments. If you've installed a mismatched version and encounter issues with ArcGIS, refer to the following troubleshooting steps:

  1. Carry out the steps for a clean uninstall ArcGIS Pro.
  2. Uninstall Visual Studio.
  3. Go to the Control Panel and verify that no .NET Framework versions are installed on your device.
  4. Carry out the installation of the ArcGIS Pro.
  5. Ensure that ArcGIS Pro is functioning correctly.
  6. Verify the .NET Framework supported by ArcGIS Pro.
  7. Install the Visual Studio version that uses the same NET Framework version, or what is supported by ArcGIS Pro.
  8. Ensure that ArcGIS Pro is operating as expected.

Article ID: 000031238

Software:
  • ArcGIS Pro

Get support with AI

Resolve your issue quickly with the Esri Support AI Chatbot.

Start chatting now

Get help from ArcGIS experts

Contact technical support

Start chatting now

Go to download options