PROBLEM

Hosted imagery layer publishing and raster analysis jobs stuck after migrating to a cloud relational store in ArcGIS Enterprise on Kubernetes

Last Published: December 2, 2025

Description

After migrating from a hosted relational store to a cloud relational store, jobs for raster analysis or publishing hosted imagery layers are stuck in the esriJobSubmitted state. The updated relational store cannot be accessed, and logs show a failure to initialize JobTableStore, such as

Unable to connect to the hosted table. Failed to initialise JobTableStore

Cause

After migrating to a cloud relational store, the raster analytics and image hosting pods are not restarted, so their configurations are not updated. These pods still reference the previous hosted relational store, which is no longer available.

Solution or Workaround

To refresh all raster analytics and image hosting pods complete one of the following actions:

Completing either action will update the pod configuration. You will need to resubmit any previously stuck publishing or analysis jobs.

Article ID: 000039235

Software:
  • ArcGIS Enterprise on Kubernetes

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