PROBLEM

Hosted feature layers fail to publish after updating the ArcGIS Server License

Last Published: July 8, 2020

Description

After updating the ArcGIS Server license, users may experience issues publishing a hosted feature layer, even though the ArcGIS Server licenses were updated properly. When examining the log files, the following error may occur:

"Error: Failed to connect to the database. No ArcGIS Server license found. Contact your geodatabase administrator to update license."

The relational geodatabase also fails to validate. This is the same error the appears if you have not updated the Enterprise geodatabase. However, unlike an Enterprise geodatabase, the Data Store cannot be authorized using the geoprocessing tools in ArcMap or ArcGIS Pro. Instead, use the ArcGIS Data Store command utility reference.

Cause

The error typically occurs when the Data Store is unable to receive data from the client during the time the ArcGIS Server license was updated. 

Solution or Workaround

  1. Copy the following path from your end:
C:\programfiles\ArcGIS\DataStore\tools
  1. Run the command prompt as an administrator.
  2. Type the following:
cd C:\programfiles\ArcGIS\DataStore\tools
  • Press Enter.
  • Run the update license command:
C:\programfiles\ArcGIS\DataStore\tools>updatelicense.bat

Article ID: 000023537

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