PROBLEM

GeoPackage (.gpkg) is not visible in the Catalog view in ArcCatalog or ArcMap

Last Published: January 26, 2022

Description

When navigating to a directory that contains GeoPackage (.gpkg) data, ArcCatalog/ArcMap do not display them.

Note:
This article applies to retired ArcGIS versions 10.2.x. Later versions of ArcGIS may contain different functionality, as well as different names and locations for menus, commands and geoprocessing tools.

Cause

ArcGIS Desktop 10.2 has already been installed and Catalog used. Installing 10.2.1 or 10.2.2 does not show .gkpg files because the cache file is outdated.

Solution or Workaround

Delete the cache files (GxDBFactCache.dat, GxObjFactCache.dat) in:

%USERPROFILE%\AppData\Roaming\ESRI\Desktop10.2\ArcCatalog

This causes the cache files to be regenerated, and the .gpkg files are then visible.

Article ID: 000012010

Software:
  • ArcMap

Receive notifications and find solutions for new or common issues

Get summarized answers and video solutions from our new AI chatbot.

Download the Esri Support App

Discover more on this topic

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options