ERROR

FATAL:java.net.BindException: Address in use

Last Published: April 25, 2020

Error Message

When attempting to run startup.bat from <drive>:\jakarta-tomcat-3.2\bin, the following error message occurs:

FATAL:java.net.BindException: Address in use: bind
java.net.BindException: Address in use: bind
at java.net.PlainSocketImpl.socketBind(Native Method)
at java.net.PlainSocketImpl.bind(PlainSocketImpl.java:390)
at java.net.ServerSocket.<init>(ServerSocket.java:173)
at java.net.ServerSocket.<init>(ServerSocket.java:124)
at org.apache.tomcat.net.DefaultServerSocketFactory.createSocket(Default
ServerSocketFactory.java:97)
at org.apache.tomcat.service.SimpleTcpEndpoint.startEndpoint(SimpleTcpEn
dpoint.java:186)
at org.apache.tomcat.service.SimpleTcpConnector.start(SimpleTcpConnector
.java:142)
at org.apache.tomcat.core.ContextManager.start(ContextManager.java, Comp
iled Code)
at org.apache.tomcat.startup.Tomcat.execute(Tomcat.java:157)
at org.apache.tomcat.startup.Tomcat.main(Tomcat.java:163)

Cause

Another application or service is already accessing port 8080. On Windows, it could be a service installed on some Dell servers. The service name is 'dellw3j' and it uses port 8007.

Solution or Workaround



  1. Stop the service that is using port 8080.

    Note:
    See Related Information to download fport v1.33. This program reports all open TCP/IP and UDP ports and maps them to the owning application.

  2. Rerun startup.bat.

Article ID:000004696

Software:
  • Legacy Products

Receive notifications and find solutions for new or common issues

Get summarized answers and video solutions from our new AI chatbot.

Download the Esri Support App

Related Information

Discover more on this topic

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options