ERROR

Failed to join site, failed to register the server machine. Unable to access SDE datastore

Last Published: April 25, 2020

Error Message

When attempting to join a newly installed instance of ArcGIS for Server 10.1 to an existing site, the following error is returned:

"Failed to join site, failed to register the server machine. Unable to access SDE datastore."

Cause

To join the existing ArcGIS Server site, the new machine must be able to connect to and validate any datastore or database connections. If it cannot connect to and validate the database connections, it does not join the existing ArcGIS Server site.

Solution or Workaround

To connect to and validate database connections, the native client for the database must be installed.

  1. Download the native client for the database used on the ArcGIS Server site. This native client can be obtained from the Esri Customer Care Portal.

    a) Log in to the Customer Care Portal.

    b) Click the Software Download icon.

    c) Click 'DBMS Support Files for ArcGIS 10.1'.

    d) Find the correct DBMS native client for the current environment and click the Download button.

  2. Launch the downloaded file using the Esri Download Manager.

    a) When the Esri Download Manager screen is displayed, click the button to download the file and follow the prompts to save the file to a preferred location.

    b) After the file downloads, click the Launch button to copy the contents of the download the the appropriate location.

  3. Join the new machine to the existing ArcGIS Server site in the Manager interface.

    a) Open a web browser and go to:

    http://<servername>:6080/arcgis/manager

    b) Click 'Join an Existing Site'. Follow the prompts to join the existing ArcGIS Server site.

Article ID: 000011830

Software:
  • ArcGIS Server

Receive notifications and find solutions for new or common issues

Get summarized answers and video solutions from our new AI chatbot.

Download the Esri Support App

Discover more on this topic

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options