Error Message
Working with large amounts of data from .las or .zlas files can cause the Build LAS Dataset Pyramid (Data Management) tool to fail. This article deals with the technical evaluation of this problem.
Cause
The cause of the problem is often related to insufficient space in the Scratch Workspace. The data size of the .las or .zlas files has exceeded the available space.
Solution or Workaround
- Ensure that the Scratch Workspace is set to a location with enough storage space. The temporary files created in the Scratch Workspace are approximately half the size of the .las files or the size of the uncompressed .zlas files.
- Move the Scratch Workspace to another drive with enough free space. This can be done using the Global Environment Settings: Analysis tab > Geoprocessing > Environment.
- Note that the pyramid is typically one third of the total size of the .las files referenced by the LAS dataset. The LAS dataset pyramid is stored in the same location as the LAS dataset, in a directory whose name begins with the name of the LAS dataset and ends with .slas.
Refer to the Related Information section for more details.