ERROR

Failed to connect to database. Cannot connect to database because the database client software failed to load. Be sure the database client software...

Last Published: March 30, 2023

Error Message

When attempting to establish a connection to a supported SAP HANA database in ArcCatalog on a Windows machine, the following error message may be returned:

Error:   
"Failed to connect to database.
Cannot connect to database because the database client software failed to load.
Be sure the database client software is installed and configured correctly."
image of error message

Cause

The ArcGIS client requires the SAP HANA client directory to be set in the Windows PATH environment variable.

Solution or Workaround

Update the PATH environment variable by putting the SAP client directory path at the beginning. By default, the client file is located in:

C:\Program Files (x86)\sap\hdbclient
System Properties, Advanced tab

Article ID: 000012678

Software:
  • ArcMap 10 x

Receive notifications and find solutions for new or common issues

Get summarized answers and video solutions from our new AI chatbot.

Download the Esri Support App

Discover more on this topic

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options