ERROR

You don't have permission to access Navigator

Last Published: May 18, 2021

Error Message

When attempting to log in to the ArcGIS Navigator app with an ArcGIS Online account, the login fails, and returns the following error:

Error:   
You don't have permission to access Navigator.
The error message

Cause

The ArcGIS Online account used to log in is not assigned a license for ArcGIS Navigator.

Solution or Workaround

To resolve, assign an ArcGIS Navigator license to the account in ArcGIS Online.

  1. Log in to ArcGIS Online as an administrator.
  2. Navigate to Organization > Licenses > Add-on licenses.
The Esri Support Services window in ArcGIS Online with the Organization and Licences tabs.
  1. Scroll to the Applications drop-down list.
  2. Click Manage under ArcGIS Navigator.
The ArcGIS Navigator page to open a window to assign or remove ArcGIS Navigator licenses from an account.
  1. In the Manage: ArcGIS Navigator window, enter the name of the account to assign the ArcGIS Navigator license to in the Search members field.
  2. Beside the account name, toggle the license on to activate the ArcGIS Navigator license assignment.
The Manage licenses toggle next to the account name to assign the account an ArcGIS Navigator license.

Article ID:000025586

Software:
  • ArcGIS Navigator
  • ArcGIS Online

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