ERROR

Windows could not start the Portal for ArcGIS service on Local computer. Error 1067: The process was terminated unexpectedly

Last Published: May 3, 2022

Error Message

After upgrading Portal for ArcGIS, attempting to start the Portal service in Windows Services fails, and returns the error message:

Error:   
Windows could not start the Portal for ArcGIS service on Local computer. Error 1067: The process was terminated unexpectedly.

Performing a software repair on Portal for ArcGIS does not resolve the issue.

Cause

The upgrade process did not complete. The initial step of the upgrade is successful, but the upgrade process does not reach the 'Continue Portal Upgrade' step as detailed in ArcGIS Enterprise: Perform an upgrade of your portal deployment.

An additional source of this error may be an updated service account password that was not then updated in the Portal for ArcGIS identity store. 

Solution or Workaround

To resolve, reinstall the previous version of Portal used prior to the upgrade process, connect this version to the original content directory, and perform the software upgrade once more.

Warning:   
The instructions below include making changes to essential parts of the ArcGIS Enterprise deployment. Esri recommends performing a backup of the ArcGIS Enterprise machine, including the registry, before proceeding. Esri cannot guarantee results from incorrect modifications while following these instructions. Exercise caution. Consult a qualified computer systems professional if necessary.
  1. Perform a backup of the portal content directory, and save the backup in a temporary location.
  2. Uninstall Portal for ArcGIS. For steps, refer to Microsoft: Uninstall or remove apps and programs in Windows 10.
  3. Reinstall the previous version of Portal. For steps, refer to ArcGIS Enterprise: Installing Portal for ArcGIS.
  4. Once the installation is complete, create the Portal for ArcGIS site by pointing it to the original content directory location.
  5. Log in to the Portal Administrator Directory as an administrator, and change the log level settings to Debug. For steps, refer to ArcGIS Enterprise: Specify portal log settings.
  6. Perform the Portal for ArcGIS upgrade process. For steps, refer to ArcGIS Enterprise: Perform an upgrade of your portal deployment.

Article ID: 000025042

Software:
  • Portal for ArcGIS

Receive notifications and find solutions for new or common issues

Get summarized answers and video solutions from our new AI chatbot.

Download the Esri Support App

Related Information

Discover more on this topic

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options