ERROR

"GenerateRaster failed...ContainerNotFound" when running certain Raster Analysis tools

Last Published: December 5, 2025

Error Message

In some scenarios, a specific organization may be unable to successfully run specific Raster Analysis tools, such as the 'Extract Data' tool. An error is returned similar to the following:

"Error
GenerateRaster failed. Cause of failure: A raster error has occurred. The messages that follow will provide more detail. Cause of failure: ï»^ContainerNotFound The specified container does not exist. Cause of failure:Requestld:<redacted_reqID>. Cause of failure: VSISync, Path:
C:\Users\arcgis\AppData\Local\ESRI\LocaI Caches\MapCacheV1\_cloudStores_<redacted>\<LAYER NAME>\conf.json]. Cause of failure: code:500, There is no multidimensionlnfo available., Generic Server Error., Internal server error. Cause of failure: Failed to execute (GenerateRasterFromRasterFunction)."

This issue is not specific to a user, but rather an entire organization. It is not reproducible in Esri Support as the underlying root cause is due to insufficient imagery usage in the organization to trigger specific backend processes that allow for proper storage of raster data. If a customer encounters this specific error, the workaround is very straightforward and easy to resolve. 

Cause

This is caused by an automatic backend process that is not triggered before the Raster Analysis tool is run and therefore a specific capability is not applied to the organization. Users will experience this infrequently and only when they've done limited imagery workflows in the organization before running certain Raster Analysis tools.

Solution or Workaround

The fastest and easiest way to resolve this issue is to publish a single image to the ArcGIS Online Organization to create a Tiled Imagery Layer (TIL). The publishing process triggers the backend functionality that is necessary to run the Extract Data tool and store the output layer. Any image or tile layer that is published to the organization will suffice. 

Once this item is uploaded and published to the organization, the tool(s) execute successfully. The success of the Extract Data tool is not contingent upon that .tpkx item or the hosted tile layer remaining in the organization after its initial publish. Users who follow this workflow to circumvent that error can delete the test tiled imagery layer immediately.

Article ID: 000032428

Software:
  • ArcGIS Online

Get support with AI

Resolve your issue quickly with the Esri Support AI Chatbot.

Start chatting now

Related Information

Discover more on this topic

Get help from ArcGIS experts

Contact technical support

Start chatting now

Go to download options