ERROR

Unable to open network table with a specific version

Last Published: April 25, 2020

Error Message

***ESRI INTERNAL ONLY***In ArcCatalog featureclass preview:
"Error opening featureclass. Unable to open network table". In ArcMap:
Application crashes with no error message
when switching to the problem version.

Cause

There are duplicate rows when opening the N_#_Props table. When running an ArcSDE client Intercept, scroll down to the bottom and 18 rows are returned for the N_#_Props table. The # in the N_#_Props table name corresponds to the unique ID of the geometric network's logical network from the GDB_Networks system table.

In the case below, when querying the actual N_#_Props table only 9 unique rows display. In this case, the N_13_Props table is identified as the problem with 18 rows returned.

From SDE_client Intercept file:

[W 08:56] Command: QueryLayer
[W 08:56] Long: 1
[W 08:56] Query Info:
Num Columns: 1
Columns: *
SQL_Construct: [1]
Tables: ARCFM.N_13_Props
WhereClause: <null>
Query Type: 0
ByClause: <null>
Num Hints: 0
Hints: Num Parameter markers: 0

Logfile: <null>
[R 08:56] Long: 0
[R 08:56] Col_Defines: [3]
Name Type Width nDec NULL? RowID
-------------------------------- ----------- ----- ---- -------- -----
PROPERTYID SE_INT32 10 0 NOT NULL SDE
PROPERTYNAME SE_STRING 32 0 NOT NULL
PROPERTYVALUE SE_INT32 9 0 NOT NULL
-------------------------------- ----------- ----- ---- -------- -----
========================================
[W 08:56] Command: ExecuteSpatialQuery
[W 08:56] Long: 1
[R 08:56] Long: 0
========================================
[W 08:56] Command: NextBuffer
[W 08:56] Long: 1
[R 08:56] Long: 0
[R 08:56] Long: 584
[R 08:56] Long: 18
[R 08:56] Short: -1
[R 08:56] Long: 1
[R 08:56] Long: 0
[R 08:56] Block:
BufferInfo: [25/584]
BufferInHex: "02000200020006000000110000004D6178204A756E6374696F..."
========================================
[W 08:56] Command: CloseStream
[W 08:56] Long: 1
[W 08:56] Long: 1
[R 08:56] Long: 0

Solution or Workaround

Follow the steps below:

a) Make a backup copy of the database.

b) If running against an Oracle instance, ensure that the SDE user (ArcSDE administrator) has been granted the following privileges:

ALTER ANY INDEX
ALTER ANY TABLE
ANALYZE ANY
CREATE ANY INDEX
CREATE ANY PROCEDURE
CREATE ANY SEQUENCE
CREATE ANY TRIGGER
CREATE ANY VIEW
CREATE SESSION
DROP ANY INDEX
DROP ANY TABLE
DROP ANY VIEW
DROP ANY PROCEDURE
DROP ANY SEQUENCE
EXECUTE ANY PROCEDURE
SELECT ANY SEQUENCE
SELECT ANY TABLE
UNLIMITED TABLESPACE

c) Disconnect all users from ArcSDE, and verify that no users are connected by running sdemon -o info -I users.

d) open a command prompt on the SDE Server and type:

sdegdbrepair -o repair -r <owner.network_table_name> -V <owner.version_name> -u <sde_username> -p <sde_password>

EXAMPLE:
sdegdbrepair -o repair -r <ARCFM.N_13_Props> -V <SDE.MASTER> -u <sde_username> -p <sde_password>

The utility should repair the table successfully. Hopefully this will not be a recurring issue, but if the problem is encountered again, the solution is to use the repair utility.

If the user asks for an explanation, say that this is "unusual behavior" that is not yet reproducible.

Other syntax options available:

-o repair [-H <sde_directory>] [-u <DB_Admin_user>] [-p <DB_Admin_password>]
[-r versioned table name | file=<table_list>]
[-V {ALL | NONE | <version_name>}]
[-D <database>] [-s datasource] [-l <key>]

    Article ID:000008669

    Software:
    • ArcMap 9 x
    • Legacy Products

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