ERROR

Unable to generate token. [Invalid username or password]

Last Published: August 18, 2021

Error Message

In some instances, when adding an ArcGIS Online connection to the ArcGIS GeoEvent Server's data stores, the connection fails to establish, returning the following error message:

Error:   
Unable to generate token. [Invalid username or password.]
The error message: Unable to generate token. [Invalid username or password]

Cause

  • An incorrect letter case is used in the login credentials.
  • A proxy is used on the machine.

Solution or Workaround

Depending on the cause, complete one of the workarounds provided to resolve the error.

Use the correct letter case for the login credentials

ArcGIS GeoEvent Server is case-sensitive when accepting credentials from ArcGIS Online. Resolve this issue by using the correct case for the username as in ArcGIS Online.

Add ArcGIS Online to the allow list to enable connection access

A proxy can prevent ArcGIS GeoEvent Server from communicating with ArcGIS Online servers. On the machine, navigate to the Start menu > Internet Options > Connections. Under Local Area Network (LAN) settings, click LAN settings to check if a proxy is used on the machine. If a proxy is used, ensure the ArcGIS user account has access to the internet by attempting to access the internet using a browser. The system administrator must grant access to the ArcGIS user account by adding the user account into the proxy server's allow list to enable the connection to ArcGIS Online. Refer to How To: Configure ArcGIS GeoEvent Processor to use an HTTP Client Proxy for more information.

Article ID:000024909

Software:
  • ArcGIS GeoEvent Server
  • ArcGIS Online

Receive notifications and find solutions for new or common issues

Get summarized answers and video solutions from our new AI chatbot.

Download the Esri Support App

Related Information

Discover more on this topic

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options