ERROR

The following must be resolved to run this setup program: <Esri Product><Version Number> needs to be removed

Last Published: June 4, 2022

Error Message

Attempts to run the ArcGIS Enterprise Builder installation program to upgrade an ArcGIS Enterprise deployment fail, and the following error message is returned:

Error:
The following must be resolved to run this setup program:
<Esri Product><Version Number> needs to be removed.
The error message returned when attempting to upgrade ArcGIS Enterprise using ArcGIS Enterprise Builder

Cause

The error message is returned when ArcGIS Enterprise Builder is used to upgrade an ArcGIS Enterprise deployment with components that are individually installed, and with versions that do not match the ArcGIS Enterprise Builder version. ArcGIS Enterprise Builder can only upgrade ArcGIS Enterprise components previously installed using ArcGIS Enterprise Builder.

All ArcGIS Enterprise components, consisting of ArcGIS Server, Portal for ArcGIS, ArcGIS Web Adaptor, ArcGIS Data Store, and additional ArcGIS Server sites, must match the version of ArcGIS Enterprise Builder before running ArcGIS Enterprise Builder. As an example, if ArcGIS Enterprise Builder 10.9.1 is used to upgrade an ArcGIS Enterprise deployment, and Portal for ArcGIS 10.7.1 is installed from the previous deployment, the upgrade process fails.

Solution or Workaround

Upgrade all components of ArcGIS Enterprise individually to match the ArcGIS Enterprise Builder version before installing ArcGIS Enterprise Builder. Refer to ArcGIS Enterprise: Upgrade an ArcGIS Enterprise deployment for instructions.

Article ID:000027782

Software:
  • Portal for ArcGIS
  • ArcGIS Server
  • ArcGIS Enterprise Builder

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Related Information

Discover more on this topic