ERROR

<service name> can not open file <full path name>. The system cannot find the path specified. Probable cause: The file is inaccessible to Server

Last Published: April 25, 2020

Error Message

When attempting to overwrite and restart existing ArcGIS Server services, the following error is returned:

Error:   
The system cannot find path specified. Probable cause: The file is inaccessible to Server.

Cause

This issue occurs if the machine contains two ArcGIS Server directories. The existing services folders are not transferred to the new 'arcgisinput' folder commonly located at:

arcgisserver\directories\arcgissystem\arcgisinput

The services' folders store all MXDs that are used to publish the services. Without the MXDs, the server is unable to overwrite or restart the existing services.

Note:
This issue does not occur when publishing new services.

Solution or Workaround

To resolve this issue, navigate to the old arcgisinput folder, copy the existing services' folders, and paste the folders in the new arcgisinput folder location. Once the folders are transferred, existing services can be overwritten and restarted.

Article ID:000017944

Software:
  • ArcGIS Server

Receive notifications and find solutions for new or common issues

Get summarized answers and video solutions from our new AI chatbot.

Download the Esri Support App

Related Information

Discover more on this topic

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options