ERROR

Portal for ArcGIS: No valid user license type provision currently effective. Select a valid license file

First Published: July 3, 2025
Last Published: April 13, 2026

Error Message

After deleting the previous license file, attempting to authorize Portal for ArcGIS using a new license file fails and returns the following error message:

Error: No valid user license type provision that is currently effective. Please select a valid license file.
The error message when attempting to authorize Portal for ArcGIS using a new license

Cause

The newly created license file is corrupted, which may occur due to connectivity issues during the download, upload, or saving process.

Solution or Workaround

Replace the license file with a newly generated license file for Portal for ArcGIS in My Esri.

  1. Log in to My Esri and cancel the newly created license file for Portal for ArcGIS. Refer to How To: Cancel license files for Portal for ArcGIS in My Esri for instructions.
Note: 
Licenses typically become available in My Esri within 1 to 5 minutes.
  1. Create a new license file for Portal for ArcGIS from My Esri. Refer to ArcGIS Enterprise: Obtain a portal license file from My Esri for instructions.
  2. Import the new license file into the ArcGIS Enterprise portal. Refer to Portal for ArcGIS: Import licenses in the portal for instructions.

Article ID: 000036914

Software:
  • Portal for ArcGIS
  • ArcGIS Enterprise

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