Solution or Workaround
Summary
Running INSTALL or starting ARC returns the message:
No/wrong key, printer off/not ready check equipment and press enter.
Sometimes this message happens only in ARCPLOT and ARCEDIT.
Cause
1. The hardware key may not be attached to parallel port #1 (LPT1).
2. A printer is attached to the key through LPT1 but the printer is off.
3. The PC may have a bi-directional parallel port.
4. The INSTALL program only may not be recognizing the key.
5. The hardware key may be bad.
6. The parallel port is bad.
Solution
1. Make sure the hardware key is attached to LPT1.
2. Make sure the printer is on. You may also try disconnecting and reconnecting the printer cable.
3. Make sure LPT1 is configured as a uni-directional port. PC ARC/INFO's key protection software was designed to work with uni-directional parallel ports and may have difficulty recognizing the key through a bi-directional port.
On some PCs you can change the directionality via the CMOS setup. For example, on some DELL and IBM PCs, a setting called 'arbitration level' can be changed from 'PS/2 mode' to 'Compatible' or 'AT mode'.
Other PC vendors distribute a utility to change the mode. For example ZEOS PCs can be reconfigured by a utility called 'PMODE'. IBM has a utility called 'LPTMODE'.
Yet other PCs cannot be reconfigured. In this case an I/O board with a uni-directional port must be obtained and configured to be LPT1.
4. On some PCs, only the INSTALL program will produce the error message. The INSTALL program in the ARCEXE\INSTALL directory simply adds a few lines to the AUTOEXEC.BAT directory. INSTALL can be bypassed and PC ARC/INFO can be configured manually. Assuming PC ARC/INFO is installed on the C: drive, add the path C:\ARCEXE\CMD to the PATH statement in AUTOEXEC.BAT. Also, add these environment statements to AUTOEXEC.BAT:
SET ARC=C:\ARCEXE
SET CGIPATH=C:\ARCEXE\CMD
Reboot your PC and start ARC. The error message may no longer not occur.
5. If possible, try another key known to work on the problem PC. If it works, then the original key is bad. Else, attempt to install and start PC ARC/INFO on a different PC. If the key is not recognized on that PC as well, then there is a good chance that the key is bad. Contact ESRI Customer Service for a replacement key.
6. Test the port by trying to print through it. If after trying all the above steps you still don't get any output on the printer, the port may be bad. If the error message occurs intermittently, it may be due to a faulty port. You may need a technician to replace the port.
Note:
Domestic versions of PC ARC/INFO 3.5.2 do not use a hardware key. International versions of PC ARC/INFO 3.5.2 require a hardware key, but accept the hardware key on uni-directional and bi-directional parallel ports.
Note:
To contact Rainbow Technologies, the maker of the Sentinel Pro hardware key, call (714) 454-2100.