Error Message
When setting up a system counter in ArcGIS Monitor, testing the counter fails, and returns the error message below.
Error:
Not connected RPC server is unavailable. (-2147023174)\r\n
Cause
The Distributed COM (DCOM) and Windows Management Instrumentation (WMI) settings are not enabled, and there are no firewall inbound rules set on the target server to allow the ArcGIS Monitor system counter to create a connection.
Solution or Workaround
- On the target server, navigate to Windows Administrative Tools > Computer Management.
- In the Computer Management window, expand Services and Applications.
- Right-click WMI Control, and select Properties.
- In the WMI Control Properties window, select the Security tab, and click Security.
- Click Add to add the ArcGIS Monitor Server domain user, and check the Remote Enable checkbox for the newly added user.
- Launch Windows Defender Firewall with Advanced Security. Right-click Inbound Rules, and select New Rule... to launch the new Inbound Rules wizard.
- Select Remote Assistance from the Predefined drop-down list. Click Next.
- Check all the Remote Assistance rules, and click Next.
- Select Allow the connection, and click Finish.