ERROR

Invalid verification code while setting up multifactor authentication

Last Published: August 5, 2025

Error Message

When setting up multifactor authentication in Portal for ArcGIS the following error message is returned:

Invalid verification code

Cause

This error message is caused by the mismatch of time between the portal machine and the authenticator app (Microsoft Authenticator, Google etc.) present on the mobile device through which the verification code is being entered as these are TOTP (Time based One-Time Password) apps which depend on device time.

Solution or Workaround

Make sure that the time on the portal machine matches with the time on the mobile device. If there is even a difference of 30 seconds the generated code will be rejected. After ensuring that the time of portal machine and device are in sync, restart the set-up and scan the QR code again.

Article ID: 000035903

Software:
  • Portal for ArcGIS
  • ArcGIS Enterprise

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