Error Message
When clicking the View Map button in Metadata Explorer, the following error message may occur:"HTTP Error 404: Not Found"
Cause
One of the Metadata Explorer files references a URL that exceeds the limits for parameters passed in a URL.
Solution or Workaround
The following procedure resolves the issue at ArcIMS 4.0.x. This resolution has also been incorporated into ArcIMS for the next release.
- Locate the Metadata Explorer's map_view.htm file. This file will be found in the <<servlet engine>>\metadataexplorer folder.
- Rename the map_view.htm file to map_loading.jsp.
- Find the content_frames.jsp file located in the same \metadataexplorer folder.
- Open content_frames.jsp in a text editor, such as Notepad.
- Find all occurences of 'map_view.htm' and replace them with 'map_loading.jsp'. The quotation marks are for clarity, and should be ignored when actually performing this step.
- Save and close the content_frames.jsp file.
- Stop the ArcIMS services in this order: Tasker, Monitor, AppServer.
<a href='http://support.esri.com/en/knowledgebase/techarticles/detail/23705' target='_blank'>[O] - Stop and Start ArcIMS Windows services</a> - Stop and restart the Web server service(s).
- Restart the ArcIMS services in this order: AppServer, Monitor, Tasker.
<a href='http://support.esri.com/en/knowledgebase/techarticles/detail/23705' target='_blank'>[O] - Stop and Start ArcIMS Windows services</a>