ERROR

Failure to access the DBMS server [08S01:[Microsoft][SQL Server Native Client 11.0]TCP Provider: An existing connection was forcibly closed by the remote host

Last Published: April 25, 2020

Error Message

In some instances, attempts to connect to an SQL Server database fail and the following error message is returned:

Error:   
Failure to access the DBMS server [08S01:[Microsoft][SQL Server Native Client 11.0]TCP Provider: An existing connection was forcibly closed by the remote host.

The following error may also be returned in the server logs:

Error:   
Failure to access the DBMS server [Microsoft][ODBC Driver 11 for SQL Server] Communication link failure]"

Cause

Connection between ArcGIS Desktop applications and the SQL Server database is lost when the client machine enters the sleep or power save mode, or if the connection times out.

Solution or Workaround

To circumvent this issue, perform the following steps:

  1. Check the sleep setting on the client machine and ensure it is set longer than the time the machine is idle.
Note:
In Windows 10, this setting is found under Settings > Power & Sleep. By default, Windows 10 enters the sleep mode after 30 minutes.
Image of the Windows 10 Power & Sleep Settings window.
  1. Run Device Manager, and click Network adapters. Right-click the listed network adapters, select Properties, and select the Power Management tab. Ensure the 'Allow the computer to turn off this device to save power' option is unchecked.
Image of the Network Adapters Properties window.
  1. In SQL Server Management Studio, select the Connection Properties tab. Set the Connection time-out and Execution time-out to zero. Click Connect.
Image of the Connection Properties in SQL Server Management Studio.

Article ID: 000019181

Software:
  • ArcGIS Desktop 1

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