ERROR

Failed to save. missing arguments: formItemId, featureServiceItemId, folderId, or title

Last Published: December 5, 2023

Error Message

When saving the form settings in the ArcGIS Survey123 web app, the following error is returned:

Error:   
Failed to save. missing arguments: formItemId, featureServiceItemId, folderId, or title
The error message, Failed to save. missing arguments formItemId, featureServiceItemId, folderId, or title is returned.

Cause

The folder ID does not exist in ArcGIS Online. This is due to the change of ownership of the survey. When a survey is created and published from ArcGIS Survey123 Connect, the items of the survey such as the hosted feature layer, form, and web map are stored in a folder. When there is a change in ownership, the survey items are transferred to the new owner individually, but the folder remains. Therefore, the survey folder ID for the new owner does not exist.

Solution or Workaround

In ArcGIS Online, create a new folder and move all the survey items into the new folder. For further instructions, refer to ArcGIS Online: Move multiple items.

Article ID: 000027067

Software:
  • ArcGIS Online
  • ArcGIS Survey123 Connect
  • ArcGIS Survey123 Website

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