ERROR

Failed to federate ArcGIS Server site https://FQDN/webadaptorname with Portal for ArcGIS

Last Published: May 29, 2025

Error Message

While performing a multimachine deployment, the ‘Telnet’ and ‘Ping’ operations in each machine were disabled by the organization. However, it was confirmed that the URL’s (internal as well as webadptor) of both components were accessible internally and on respective machines where other components of ArcGIS Enterprise are installed. Even after successful access to the internal URL’s, while attempting to federate the ArcGIS Server with Portal for ArcGIS, the following error message was returned:

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Cause

The ArcGIS Server and Portal for ArcGIS are installed on different machines and the ports used by these components are not accessible by the rest of the machines. Organizations may have some policies to disable the communication over ports (as shown in the image).

port unsuccessful.png

Solution or Workaround

  1. Log in to the server as an administrator where Portal for ArcGIS is installed.
  2. In the Control Panel, navigate to Windows Defender Firewall > Advanced Settings and create both inbound and outbound rules for all the ports used by Portal for ArcGIS and ArcGIS Server. Refer to Microsoft: Create Inbound Port Rule and Microsoft: Create Outbound Port Rule for instructions and more information.
  3. Repeat the above steps on the server where ArcGIS Server is installed.
  4. After the rules are created for the specified ports, check if the communication is successful using ‘Telnet’, ‘Ping’, ‘TCP test’ or any other operations permitted by the organization (as shown in the image below).
port successful.png
  1. Once the configuration is complete, federation of ArcGIS Server with Portal for ArcGIS will be successful.
Note: 
Some organizations may not grant access to make these changes in the firewall. If this issue arises, contact the organization's Network team.

Article ID: 000033965

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