ERROR

Failed to connect to the specified DBMS instance. A database connection exception has occurred. A product licensing error occurred

Last Published: December 1, 2023

Error Message

Attempts to establish a new database connection in ArcGIS Pro fail and return the following error:

Error:
Failed to connect to the specified DBMS instance. A database connection exception has occurred. A product licensing error occurred.
Connection Error message window

Cause

The keycodes file used to create the connection from ArcGIS Server is expired. The expiration date can be identified by opening the keycodes file using a text editor, for example, Notepad++, and checking the date specified in the strings provided in the file, as shown in the following image.

The expiration date in the keycodes file

Solution or Workaround

To resolve the issue, generate and retrieve the new keycodes file.

  1. Retrieve the latest version of the keycodes file depending on the following scenarios:
C:\Program Files\Esri\Licenses<version>\sysgen
  1. Connect to the database. Refer to ArcGIS Pro: Database connections in ArcGIS Pro for more information.

Article ID: 000031560

Software:
  • ArcGIS Server
  • ArcGIS Pro 3 1
  • ArcGIS Enterprise 11 0
  • ArcGIS Enterprise 11 1
  • ArcGIS Pro 3 0
  • ArcGIS Enterprise 11 2
  • ArcGIS Pro 3 2
  • ArcGIS Pro 2 9x

Receive notifications and find solutions for new or common issues

Get summarized answers and video solutions from our new AI chatbot.

Download the Esri Support App

Related Information

Discover more on this topic

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options