Error Message
Attempts to start a service in ArcGIS Server Manager fail, and the following error message is returned:
Error:
Service failed to start <serviceName>:<machineName> No Layer or Table was initialized.
Cause
- The database containing the service is not registered with ArcGIS Server.
- The data store that stores the service is not validated.
- A file or table associated with the service was renamed, preventing the service from operating correctly.
- One or more layers in the service contains a table with multiple ObjectID fields. This happens when saving joined attributes, including the joined ObjectID, to a new feature class.
- The account running ArcGIS Server does not have permission to access the underlying dataset.
Solution or Workaround
Register the database with the service stored with ArcGIS Server
Verify if the database with the service stored is registered with ArcGIS Server. If the database is not registered, refer to ArcGIS Server: Register your data with ArcGIS Server using Server Manager for instructions.
Validate the data store
Verify if the data store is validated with ArcGIS Server. If the data store is not validated, refer to How To: Validate ArcGIS Data Store for instructions.
Rename the file or table to its original name
Verify if the file or table name stored on the machine referenced by ArcGIS Server is consistent, and rename it if the name is different.
Remove any additional ObjectID field from the table
To remove a field from the layer's table in Portal for ArcGIS, refer to Portal for ArcGIS: Add or delete a field for instructions.
Grant the necessary permissions for accessing the dataset
- On the ArcGIS Server machine, navigate to the desired dataset.
- Right-click the dataset and select Properties.
- In the <Dataset_Name> Properties dialog box, click theĀ Security tab.
- Under Group or user names:, click Edit....
- In the Permission for <Dataset_Name> dialog box, select the username or group for the ArcGIS Server service account.
- Under Permissions for <ArcGIS_Server_service_account>, check the Allow check box for the Full Control option.
- Click Apply > OK.