ERROR

ArcGIS Server: Export services operation failed. A JSONObject text must begin with "{" at character 1 of

Last Published: October 29, 2024

Error Message

In a multi-machine ArcGIS Enterprise environment, the automated backup of ArcGIS Server with the Web GIS Disaster Recovery (WebGISDR) tool fails, returning the following error message in the WebGISDR log:

Error:
Failed to back up the ArcGIS Server:
Url: <URL_Path>.
{"code"500,"messages":["Export services operation failed. A JSONObject text must begin with "{" at character 1 of \u0000\u0000\u0000\....\u0000"],"status":"error"}
The error message in the WebGISDR logs

The ArcGIS Server logs reveal the following severe error message:

Error:
Webhook log: Error in Webhook Processor. init WebhookProcessors failed. Gerring WebhookProcessorsConfig failed A JSONObject text must begin with '{' at character 1 of
The error message in the ArcGIS Server logs

Cause

The webhookprocessors-config.json file is corrupted. The root cause is likely due to insufficient storage space being during the WebGISDR backup process.

The default file path directory of the webhookprocessors-config.json file is:

C:\arcgisserver\config-store\system\webhookprocessors-config

Solution or Workaround

Add braces ({}) to the webhookprocessors-config.json file

If webhooks have not been previously configured on the deployment, refer to the following workflow:

  1. On the affected machine, navigate to the webhookprocessors-config folder.
  2. Open the webhookprocessors-config.json file in a text editor, such as Notepad.
  3. Add the left brace and right brace symbols in the text editor and save the file.

The image below illustrates an example of the webhookprocessors-config.json file after completing the workflow.

The webhookprocessors-config.json file with braces

Replace the webhookprocessors-config.json file with a file from a working ArcGIS Enterprise environment

If webhooks have been previously configured on the deployment, refer to the following workflow:

  1. Obtain a webhookprocessors-config.json file from a working ArcGIS Enterprise environment.
  2. Rename the corrupted webhookprocessors-config.json file on the affected machine to webhookprocessors-config_old, and paste the working webhookprocessors-config.json file into the webhookprocessors-config folder.
  3. Open both the webhookprocessors-config_old and webhookprocessors-config.json files in a text editor, such as Notepad.
  4. Compare and modify the webhookprocessors-config.json file to match the details from the webhookprocessors-config_old file. This may involve:
    • Updating the server URLs and site ID.
    • Adjusting the file paths.
    • Ensuring the webhook configurations are accurate.
  1. Save the newly updated webhookprocessors-config.json file.

The image below illustrates an example of the webhookprocessors-config.json file after completing the workflow.

The webhookprocessors-config.json file with the updated information
Note:
For best practice, ensure sufficient storage is available for future ArcGIS Server backups to prevent this issue from recurring. Refer to Portal for ArcGIS: Manage ArcGIS Data Store backups for additional information.

Article ID: 000033352

Software:
  • ArcGIS Server
  • ArcGIS Enterprise 11 1
  • ArcGIS Enterprise 11 3
  • ArcGIS Enterprise 11 2

Receive notifications and find solutions for new or common issues

Get summarized answers and video solutions from our new AI chatbot.

Download the Esri Support App

Related Information

Discover more on this topic

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options