ERROR

ArcGIS Experience Builder: The file <file name> cannot be successfully uploaded

Last Published: October 15, 2025

Error Message

When uploading a KML file with the Add Data widget in ArcGIS Experience Builder, the upload fails and returns the following error message:

Error:
The file <file name> cannot be successfully uploaded.
The error message displayed in ArcGIS Experience Builder

The KML endpoint in the ArcGIS Portal Directory returns the following error message:

Error:
KML service is disabled.
Error: 503
The error message displayed in the ArcGIS Portal Directory

Cause

The KML service is disabled in Portal for ArcGIS. Since ArcGIS Enterprise 10.9, the enableKmlService property is available in the Portal for ArcGIS system settings. By default, this property is set to true. When the property is set to false through the ArcGIS Portal Administrator Directory, the KML service is disabled, causing KML uploads to fail.

Solution or Workaround

To enable the KML service, apply the steps below.

  1. Log in to the ArcGIS Portal Administrator Directory as an administrator.
  2. On the Site Root - / page, for Resources, click System.
  3. On the System page, for Resources, click Properties.
  4. On the System Properties page, for Resources, click Update Properties.
  5. On the Update System Properties page, in the Properties (in JSON format) text box, type the following property:
{"enableKmlService":true}
Note:
Applying the following step restarts the portal.
  1. Click Update Properties.

Article ID: 000037143

Software:
  • Portal for ArcGIS
  • ArcGIS Enterprise
  • ArcGIS Experience Builder

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