ERROR

ArcGIS Enterprise: Geodatabase Connection Properties: Bad login user

Last Published: August 20, 2024

Error Message

Attempting to connect to a PostgreSQL database in ArcGIS Pro fails with the following error message returned:

Error:
Geodatabase Connection Properties: Bad login user [ ]
The error message returned when attempting to make a connection to a PostgresSQL database in ArcGIS Pro

Cause

The pg_hba.conf file is not modified to allow other client machines, such as the client machine running ArcGIS Pro, to connect with the PostgreSQL database machine.

Solution or Workaround

  1. On the server machine with the PostgreSQL database installed, navigate to the default PostgreSQL installation folder location:
C:\Program Files\PostgreSQL\<PostgreSQL version>\data\ pg_hba.conf
  1. Add the client machine's IP address in the ADDRESS parameter to allow access to the PostgreSQL database. The following is an example:
#TYPE  DATABASE     USER    ADDRESS            METHOD

host   all          all     122.22.222.222/32   md5
The pg_hba.conf file used to modify the database ip address
Note:
On the IP address entry, add /32 at the end of the IP address if PostgreSQL cannot restart the services.
  1. Restart the PostgreSQL Windows service to reflect the changes made on the machine. In the Windows search bar, search for and open Services.
  2. Right-click the postgresql-x64-<version> - PostgreSQL Server <version> service, and click Restart.
Restarting the PostgreSQL Windows service in the Services window

Article ID: 000033362

Software:
  • Portal for ArcGIS
  • ArcGIS Pro 3 1
  • ArcGIS Enterprise 11 1
  • ArcGIS Pro 3 3
  • ArcGIS Enterprise 11 3
  • ArcGIS Enterprise 11 2
  • ArcGIS Pro 3 2

Get support with AI

Resolve your issue quickly with the Esri Support AI Chatbot.

Start chatting now

Related Information

Discover more on this topic

Get help from ArcGIS experts

Contact technical support

Start chatting now

Go to download options