ERROR

ArcGIS Enterprise: Failed to return all services configurations in the folder. Could not connect to the ArcGIS component URL

Last Published: October 7, 2024

Error Message

In the ArcGIS Enterprise portal, items are not displayed, or the portal home page does not load with the following error message returned in the ArcGIS Server logs:

Error: 
Failed to return all services configurations in the folder <Folder Name>. Could not connect to the ArcGIS component at URL <URL Address>. The ArcGIS component on that machine may not be running or the machine may not be reachable at this time.

Cause

  • The account running the ArcGIS Server service does not have permission to access the folder location.
  • Portal for ArcGIS is not fully booted up after restarting the ArcGIS Server service.

Solution or Workaround

Set folder permissions for the account running the ArcGIS Server service

Grant the necessary privileges to the ArcGIS Server account. Refer to the workaround outlined in Error: The ArcGIS Server is not able to connect to the specified directory for instructions.

Allow additional time before using the ArcGIS Enterprise portal

Allow additional time for Portal for ArcGIS to fully boot up after restarting the ArcGIS Server service, as the portal may take longer to become operational.

Article ID: 000033646

Software:
  • Portal for ArcGIS
  • ArcGIS Server
  • ArcGIS Enterprise 11 1
  • ArcGIS Enterprise 11 3
  • ArcGIS Enterprise 11 2

Receive notifications and find solutions for new or common issues

Get summarized answers and video solutions from our new AI chatbot.

Download the Esri Support App

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options